ct-Bot Firmware

Die Programmierung des c't-Bot
Nightwalker-87
Site Admin
Site Admin
Beiträge: 162
Registriert: 16 Apr 2017, 23:40

Re: ct-Bot Firmware

Beitrag von Nightwalker-87 » 19 Mär 2019, 11:23

Soweit war mir das auch schon klar.

Gemäß Makefile

Code: Alles auswählen

ifeq ($(BUILD_TARGET),armv8l-linux-gnueabihf)
CFLAGS += -mcpu=cortex-a53 -mtune=cortex-a53 -mfloat-abi=hard -mfpu=neon-fp-armv8
endif
würde "armv8l-linux-gnueabihf" für die explizite Auswahl des Build Target RPi3 dienen.

Das funktioniert so aber nicht (die Toolchain ist eingebunden und er baut auch das RPi3-Target mit wenn man nur DEVICE=PC übergibt, ohne das Target näher zu spezifizieren):

Code: Alles auswählen

git clean -dfx && make DEVICE=PC BUILD_TARGET=armv8l-linux-gnueabihf
Removing .dep/
/bin/sh: 1: armv8l-linux-gnueabihf-gcc: not found
expr: syntax error: unexpected argument ‘8’

Target device is PC atmega1284p

-------- begin --------
sh: 1: armv8l-linux-gnueabihf-g++: not found
make: *** [Makefile:456: gccversion] Error 127

Code: Alles auswählen

make DEVICE=PC -mcpu=cortex-a53
funktioniert ebenfalls nicht, ist also vermutlich falsch.

Kannst du hier mal präzisieren wie der Aufruf für RPi3 in make exakt auszusehen hat?
Bislang kann ich den selektiven Build des RPi3-Targets nur über Eclipse vornehmen.
In der Doku gibt es dazu (make) IMHO keine Angaben.
nw-87

eax
Friends of Robby
Friends of Robby
Beiträge: 765
Registriert: 18 Jan 2006, 16:16
Wohnort: Karlsruhe

Re: ct-Bot Firmware

Beitrag von eax » 20 Mär 2019, 00:23

Nightwalker-87 hat geschrieben:
19 Mär 2019, 11:23
Kannst du hier mal präzisieren wie der Aufruf für RPi3 in make exakt auszusehen hat?
Das muss so aussehen:

Code: Alles auswählen

make DEVICE=PC BUILD_TARGET=armv8l-linux-gnueabihf
Der Fehler liegt wohl hier:
Nightwalker-87 hat geschrieben:
19 Mär 2019, 11:23

Code: Alles auswählen

/bin/sh: 1: armv8l-linux-gnueabihf-gcc: not found
Der RPi3-Compiler wird nicht gefunden. Vermutlich ist $PATH nicht korrekt gesetzt, so dass armv8l-linux-gnueabihf-gcc nicht gefunden wird?
Timo -- Meine Beiträge sind unter CC-BY-SA freigegeben

Nightwalker-87
Site Admin
Site Admin
Beiträge: 162
Registriert: 16 Apr 2017, 23:40

Re: ct-Bot Firmware

Beitrag von Nightwalker-87 » 20 Mär 2019, 01:25

Ah, dann ist mir jetzt auch klar was die Ursache ist:
Die PATH Variable ist in Eclipse korrekt angepasst, was hier natürlich dann nix hilft weil make auf Systemebene $PATH abfragt, wo der Pfad dann entsprechend fehlt. #-o Diese muss nämlich mit

Code: Alles auswählen

export PATH=$PATH:/path/to/git-repo/armv8l-toolchain-linux/bin
erweitert werden.
Sry, wenn das an dieser Stelle etwas länger gedauert hat bis der Knoten geplatzt ist... :roll:
nw-87

Nightwalker-87
Site Admin
Site Admin
Beiträge: 162
Registriert: 16 Apr 2017, 23:40

Re: ct-Bot Firmware

Beitrag von Nightwalker-87 » 26 Mai 2019, 02:12

@tobi:

Nach einiger Zeit möchte ich nun diesen Thread mit seiner ursprünglichen Thema noch einmal aufgreifen. Ich habe gestern einen neuen Anlauf gestartet - diesmal jedoch mit Erfolg. Anders als zuvor, handelt es sich hierbei aber nicht um ein eigenes Git-Repository sondern um einen separaten Develop-Branch in meinem Fork von "ct-Bot". Dieser Zweig heißt ct-bot (develop_a). Ich habe den Code diesmal neben den IDEs Eclipse und Atom unter Debian Linux auch mit Eclipse unter Windows 10 erfolgreich getestet. Auch die automatisierten Travis CI Testbuilds waren alle erfolgreich.

Wenn dich das interessiert kannst du dir das also gerne mal ansehen. (Das gilt natürlich auch für alle anderen Leser.) :wink:
nw-87

VDX
Friends of Johnny-5
Friends of Johnny-5
Beiträge: 298
Registriert: 26 Jan 2006, 22:43
Wohnort: Großkrotzenburg (Main-Kinzig-Kreis)

Re: ct-Bot Firmware

Beitrag von VDX » 26 Mai 2019, 20:03

... mal schauen, ob ich über die Feiertage/Brückentage etwas Zeit finde ... bin momentan mit meinem DDL (2x200Watt-Direct-Diode-Laser) Projekt fast komplett ausgelastet :?
Ciao, Viktor --- Aufruf zum Projekt "Müll-freie Meere" - https://reprap.org/forum/list.php?426

Nightwalker-87
Site Admin
Site Admin
Beiträge: 162
Registriert: 16 Apr 2017, 23:40

Re: ct-Bot Firmware

Beitrag von Nightwalker-87 » 26 Mai 2019, 21:24

Jo, kein Thema. Vom Code her hat sich bei der Version ja ohnehin noch nichts verändert, bislang nur in der Projektstruktur welche die dafür die Grundlage bereiten soll.

Off-topic: DDL klingt natürlich auch super spannend. Per PN kannst du mir da gerne noch mehr zu erzählen. Da das weit in mein Fachgebiet hineinragt, bin ich da ganz Ohr... :wink:
nw-87

VDX
Friends of Johnny-5
Friends of Johnny-5
Beiträge: 298
Registriert: 26 Jan 2006, 22:43
Wohnort: Großkrotzenburg (Main-Kinzig-Kreis)

Re: ct-Bot Firmware

Beitrag von VDX » 27 Mai 2019, 01:35

... ein bischen was zum DDL kannst du hier nachlesen - https://reprap.org/forum/read.php?414,849307

Ist nicht so ganz "up to date", weils' RepRap eher ein 3D-Druck-Forum ist ... die eigentliche Diskussionen dazu laufen in einem CNC- und zwei Lasergravierer-Foren 8)

Viktor
Ciao, Viktor --- Aufruf zum Projekt "Müll-freie Meere" - https://reprap.org/forum/list.php?426

Antworten